Error during rendering! - out of nowhere. Help - Solved!

What is this?.. For unknown reason rendering with DAZ just stopped working. Preview rendering in the viewport works normal. This ‘very informative’ error message appears when I hit Render, as in a new window. It can’t be a graphics card issue. Rendering with Blender and 3ds Max works as usual.

Anyone got any idea what could be causing this error? Unbenannt

Also i was unable to create a topic in the Official DAZ forums, so here I am…

Any render?

I found this earlier today when I was troublshooting something similar. This didn’t apply to me, but it’s a quick check.

Yes, as I wrote Nvidia preview in the viewport is working fine. but when I hit the Render button, to fully render in 1080p for instance and output the file, I just get the error message. Same thing with an empty scene.

After that i get a second error message that says: “Unable to render. Renderer is already in use”

Can you paste a screenshot of your Render Settings Tab with the “Currently Used” section highlighted?

yep, here it is

I’m assuming you left the MaxTime at 7200 seconds.

I don’t see anything out of the ordinary. Frankly I wanted to make sure you didn’t have Max Samples set to zero which would result in a blank render. (I usually set mine to -1 and use Render Quality to have the renderer take as many samples as needed to get the convergence I want.)

The next thing would be checking the log file.

Help → Troubleshooting → View Log File

But if you’ve never cleared it it’s probably going to be super huge.

I recommend deleting the file (it’s not usually locked) and then try a new render. That way the only thing in the logs should be entries related.

It will give you an idea what’s going on.

Are you still running the preview while the rendering is trying to take place?

@mjc3d well, there is just one warning in the error-log, maybe that’ll give us a clue.

@Garebear No, I usually switch back to texture shaded preview, before rendering. But i think that might be exactly what DAZ is assuming…

Probably. Or maybe something in the software is making it think that it is still rendering for some reason. That was just the first thought that popped into my head after reading your situation.

I don’t know enough about the software or other software to make assumptions on how they interact with each other or if they can play off each other when it comes to rendering either. But if I see or hear anything as well that might help I will let you know.

Well that log is not very telling at all actually. :slight_smile:

Usually it’s full of info about your graphics card, driver (version), memory for the scene, etc.

Here’s a wild thought…

Have you tried rebooting your machine? Or updating your Nvidia drivers?

Maybe something low-level is hung up.

DAZ just uses nVidias Iray SDK/ APIs to render and isn’t talking to your card directly.

Alright, i cleared it up, since you mentioned doing so in the previous post. Here is a log.txt file that contains more information. This is after rebooting my system. File on MEGA

it shows lot of stuff NOT INITIALIZED

Updated the graphics drivers two weeks ago… Anyway I’ll try the most recent one, tomorrow.

Thank you for all your suggestions

The good news is Studio is seeing your GPU. So that’s a good sign. And it’s communicating with your GPU.

2021-06-14 00:26:11.192 NVIDIA Iray GPUs:
2021-06-14 00:26:11.192 	GPU: 1 - NVIDIA GeForce GTX 1080 Ti
2021-06-14 00:26:11.192 	Memory Size: 10.9 GB
2021-06-14 00:26:11.193 	Clock Rate: 1683000 kHz
2021-06-14 00:26:11.193 	Multi Processor Count: 28
2021-06-14 00:26:11.193 	CUDA Device ID: 0
2021-06-14 00:26:11.193 	CUDA Compute Capability: 6.1
2021-06-14 00:26:11.193 	PCI Bus ID: 1
2021-06-14 00:26:11.193 	PCI Device ID: 0
2021-06-14 00:26:11.193 	TCC Mode: disabled
2021-06-14 00:26:11.193 	Display: attached
2021-06-14 00:26:11.193 NVIDIA Iray Scheduling Configuration:
2021-06-14 00:26:11.193 	CPU Load Limit: 8
2021-06-14 00:26:11.193 	CPU Thread Affinity: disabled
2021-06-14 00:26:11.193 	GPU Load Limit: 1
2021-06-14 00:26:11.452 Total class factories: 2030
2021-06-14 00:26:11.453 Creating Script Engine...
2021-06-14 00:26:11.468 WARNING: 3DConnexion Plug-in Error: Could not create Device, CoCreateInstance failed
2021-06-14 00:26:11.468 3D mouse support library could not be loaded.
2021-06-14 00:26:11.474 Creating Main Window...
2021-06-14 00:26:11.475 Creating Viewport Manager...
2021-06-14 00:26:11.526 Successfully created OpenGL viewport for Viewport1.
2021-06-14 00:26:11.640 Successfully created OpenGL viewport for Viewport2.
2021-06-14 00:26:11.718 Successfully created OpenGL viewport for Viewport3.
2021-06-14 00:26:11.794 Successfully created OpenGL viewport for Viewport4.
2021-06-14 00:26:11.882 Creating Action Manager...
2021-06-14 00:26:11.891 Creating Pane Manager...
2021-06-14 00:26:12.035 Successfully created OpenGL viewport for AuxViewportView.
2021-06-14 00:26:13.188 Executing startup script...
2021-06-14 00:26:13.226 Started in: C:/Daz 3D/Applications/64-bit/DAZ 3D/DAZStudio4
2021-06-14 00:26:13.226 DAZ Studio Started
2021-06-14 00:26:13.227 Creating Pixel Buffer
2021-06-14 00:26:13.268 Pixel buffer - Width: 1024 Height: 1024
2021-06-14 00:26:13.272 Compiling OpenGL Shader...
2021-06-14 00:26:13.300 Fragment Shader:
Fragment Shader compiled successfully.
Linking Shader:
Shader Program successfully linked.

2021-06-14 00:26:22.756 WARNING: QColor::setRgb: RGB parameters out of range
2021-06-14 00:26:29.314 Total Rendering Time: 6.56 seconds

Here’s a crazy idea.

Try creating a new scene. Either a set/ environment or another figure.

So start fresh. Clear everything out. And try loading just a simple scene or figure.

And try to render that.

It’s possible something in your current scene is crashing the rendering engine though I would expect it would have written a log entry if that’s the case.

But something definitely is going on.

The only other thing I saw that was interesting was this:

2021-06-14 00:26:10.189 Initializing NVIDIA Iray...
2021-06-14 00:26:10.189 Iray [INFO] - API:DATABASE ::   0.0   API    db   info : Loaded "C:\Daz 3D\Applications\64-bit\DAZ 3D\DAZStudio4\libs\iray\libneuray.dll"
2021-06-14 00:26:10.189 Iray [INFO] - API:MISC ::   0.0   API    misc info : Iray RTX 2020.1.3, build 334300.6349, 14 Dec 2020, nt-x86-64
2021-06-14 00:26:10.189 WARNING: ..\..\..\..\..\src\pluginsource\DzIrayRender\dzneuraymgr.cpp(480): Could not add path: "C:/Users/Makso/AppData/Roaming/DAZ 3D/Studio4/shaders/iray". Due to unknown error -2
2021-06-14 00:26:10.190 WARNING: ..\..\..\..\..\src\pluginsource\DzIrayRender\dzneuraymgr.cpp(480): Could not add path: "C:/Users/Makso/AppData/Roaming/DAZ 3D/Studio4/temp/shaders/iray". Due to unknown error -2
2021-06-14 00:26:10.203 Iray [INFO] - GPU:RENDER ::   0.0   GPU    rend info : Found 1 GPU with vendor's API.
2021-06-14 00:26:10.216 Iray [INFO] - CUDA:RENDER ::   0.0   CUDA   rend info : Found 1 CUDA device.

Those two WARNING lines.

It’s almost like something happened to your C:/Users/Makso/AppData/Roaming/DAZ 3D/Studio4/ folder.

Have you changed permissions or adjusted the permissions on your %USERPROFILE% folder at all recently?

But then again, it’s just a warning.

Thank you so far. We definitely onto something. I noticed something odd about those two warning lines. The folders are not there. So i tried the dumbest solution first and created them manually. Here’s the odd thing, as soon as I start DAZ the folders inside /temp disappear again.

deleted by DAZ itself. ?

I don’t recall changing any permissions. However i recently run “Wise Disk Cleaner” to free up some space, which never caused any issues in the past. Updating graphics drivers and creating new fresh scene changed nothing.

The only other thing i can think of is uninstalling Studio and reinstalling it.

(It won’t delete any of your content or installed products.)

Another option you can take is to install the latest Public Beta. It installs into a completely new directory so you can run both of them concurrently (and even simultaneously though your 1080 might crawl.)

It’s a long shot, but it might prove if there’s something wrong with your Studio installation because if the Public Beta works then you pretty much know at that point it’s your Studio install.

You can install the Studio Public Beta with DAZ Installation Manager:

Select “Public Build” under “Downloads” in the “Advanced Settings” window (Gear Icon on the toolbar).

1 Like

OK I solved it. Apparently I’m not supposed to deactivate the 3Delight Renderer in the Installed Plugin Options. Even tho Iray is the renderer I prefer. DAZ coding is so strange…

I disabled some other plugins i have never used and never will, to make DAZ start and run faster. (notable speed increase) For some reason disabling 3Delight broke the rendering in new window with Iray. After enabling it again, rendering works as always.

Thanks again @mjc3d You’re the man! I only saw it only after comparing the official with the public built of DAZ which was your idea.

I’m starting to like this forum more than Reddit or the official daz forum hehe…