Geometary Shells not playing together

Can anyone explain how to make Geometary Shells play nicely with one another.

When using skin dirt mods that apply a shell to the whole figure, any prexisting geo shells (like breastacular) will turn ‘white’ in the editor.

I can fix the white out issue by going to the whole skin shell and turning opacity down on the breastacular surfaces but this leaves the breastacular area with no dirt effects applied.

I’ve read about the shell offset feature but playing with that does not seem to fix the issue.

Is there a way to combine the shells in some way so I can apply dirt to the breastacular area too.

Thanks for your help!

Select the 2nd geometry shell and increase the Mesh Offset by 0.01 increments until they no longer clash

1 Like

What @PlatnumK said. :wink:

So for example you’d want your dirt layer to be offset above your breastacular layer since dirt is usually layered on top.

Took me much too long to figure that out myself. :wink:

Thanks for the tip guys but I have tried this with no joy. I’ve attached screen shots to demonstrate (perhaps you can point to what I’m doing wrong):

So I have a default Gen8 female model with Breastacular mod added:

I then add the ‘dirt’ geo shell (and the breastacular area is now white):

I move the dirt offset to way off the model (so you can see an outline floating above the skin) but the breastacular area remains white (not what we are after):

The only way to get rid of the white effect is to turn down the opacity of the breastacular surfaces on the dirt geo shell (but that means no dirt there either) :frowning:

If you can tell me what I’m doing wrong I’ll be forever in your debt! :wink:


What happens if you:

  1. Apply Dirt Layer first.
  2. Set the offset to like 0.01 or 0.02 or so.
  3. Then apply the breastacular shell

Thanks mjc but thats not working either.

Its odd because it appears to be the dirt geo shell that has the white surface on it. If I hide the dirt shell I get this:

Its almost as if the breastacular object when applied to the figure is overwriting the dirt geoshell surfaces.

Driving me nutts!

Have you tried doing a quick render to see?

That should work.

I’m wondering if it’s not just a bug in the preview window.

I think I have breastacular. Let me try to reproduce what you’re doing.

I think I got it and I really didn’t have to do anything.

By the way I’m using SickelYield’s A Dirty Mess for Genesis 8.

I loaded Breastacular.

Then I loaded A Dirty Mess.

Then in Breastacular, I selected my G8F.

I selected the “Node Selector” under Breast Shapes.

Then selected the Fantasy 02 Shape.

And as you can see everything applied.

I didn’t even dial in any offsets.

Arrgghh… why won’t it work for me…

Its not a preview bug, here is a quick render:

Just noticed you do not have any geo shells in your scene tab. Maybe that is the difference. I’m using Aeon Soul Skin Effects for the dirt (that creates a shell and then applies a surface to it).

Do you have Golden Palace as that definetly uses a geo shell and I have the same issue with that too. Can you get that to play ball with your dirt addon?

My bad. I thought the SickelYield product used geoshells. I do have golden palace. I’ll add that now.

1 Like

Well I struck out I’m sorry.

There’s a reason MeipeX includes a “Shell Fix” script with GoldenPalace and Dicktator and some of his other products. I noticed he didn’t have a Shell Fix for Breastacular.

I tried using the ShellFix from Futalicious but all that did was bork ALL my materials and forced me to have to reload the character in the scene.

His Email is [email protected]. It may be worth reaching out to him.

You are not going insane. Something weird is going on and I’m convinced now it’s an issue with Breastacular.

Very weird.

Thanks for all your efforts trying to figure it out. Glad its not just me being stupid! :slight_smile:

I’ll try emailing that guy and see what he says.

Yes I’ve come across these shell fix scripts in certain products but they don’t seem to help mostly. I’d love to know what they are trying to do, wonder if you can read the scripts like code to find out?


Unfortunately Meipe has chosen to encrypt those so they’re not readable.